>
>
>

niepoprawny format xml?

krzysztoff7
2017/10/06 12:12:16   
Odpowiedź Forum GPSodpowiedz

Witam, pobierając punkty POI otrzymuję pliki rozpoczynające się następująco:

/n

znak /n powoduje, że plik xml nie przechodzi walidacji. Można to sprawdzić pierwszym lepszym walidatorem online choćby tym:

https //www.xmlvalidation.com/

Przyznam szczerze - nie wiem dlaczego tak się dzieje, czy w zamyśle miał być to znak nowej linii... (ukośnik powinien być w drugą stronę) w każdym razie mercedes nie odczytuje tego pliku i zawiesza się ekranie importowania danych. Czekałem prawie godzinę przy pliku zawierającym zaledwie około 200 wpisów. Po usunięciu felernego znaku odczyt POI odbywa się natychmiastowo dlatego wydaje mi się, że coś macie nie tak z tymi plikami. Pozdrawiam

Opublikuj
Anuluj

Forum Nawigacji GPS
PoiPoint

krzysztoff7
2017/10/06 12:13:56   
Odpowiedź Forum GPSodpowiedz

przepraszam, forum nie akceptuje tagów xml. Podaje linka do fragmentu pliku xml o którym wspominam na początku posta:

wklej.org/id/3266006/

Opublikuj
Anuluj

cikago
2017/10/14 07:47:53   
Odpowiedź Forum GPSodpowiedz

Cytat użytkownika krzysztoff7:

Witam, pobierając punkty POI otrzymuję pliki rozpoczynające się następująco:

/n

znak /n powoduje, że plik xml nie przechodzi walidacji. Można to sprawdzić pierwszym lepszym walidatorem online choćby tym:

https //www.xmlvalidation.com/

Przyznam szczerze - nie wiem dlaczego tak się dzieje, czy w zamyśle miał być to znak nowej linii... (ukośnik powinien być w drugą stronę) w każdym razie mercedes nie odczytuje tego pliku i zawiesza się ekranie importowania danych. Czekałem prawie godzinę przy pliku zawierającym zaledwie około 200 wpisów. Po usunięciu felernego znaku odczyt POI odbywa się natychmiastowo dlatego wydaje mi się, że coś macie nie tak z tymi plikami. Pozdrawiam


Błąd został naprawiony.

Opublikuj
Anuluj

Dodaj odpowiedź
Opublikuj Odpowiedź